Some registrars receiving 2400 Command Failed on EPP <domain:info> commands
Incident Report for eco Domain Registry
Postmortem

Incident report - 2400 Command Failed on EPP domain:info commands

After the latest release of the .eco registry system on 2023-11-16, some registrars reported receiving errors when executing domain:info commands via EPP. This may have caused issues for registrars and .eco registrants performing operations on registered .eco domains.

We apologize for this incident and any inconvenience it caused to our registrar partners and .eco registrants. This report reviews the timeline of the issue, investigates its cause, and details our learnings and the actions that we are planning to take.

Root cause analysis

The 8.13 release of the .eco registry system contained a new version of the Fury EPP extension, Fury-2.1. There was a defect in the new version of the extension that caused errors when using the domain:info command. If the Fury-2.1 extension was requested during the EPP login session then the registrar would receive an 2400 Command Failed error when executing the domain:info command.

Once the registry became aware of the issue, the support team investigated the cause and worked with our registrar partners to work around the issue by downgrading to the Fury-2.0 extension. A new version of the registry system was deployed that fixed the defect.

Some registrars may have code that automatically uses the latest version of EPP extensions. This was unanticipated and is a useful learning for the registry. If this is the case for your registrar, we would like to better understand the rationale for this behavior.

Please note that there may be other changes to make when upgrading to the new version of an EPP extension. We recommend reviewing the specification and testing the changes, prior to using the new version of an extension.

Incident Impact

We have determined that this incident affected 6 registrar partners that had started using the new version of the extension. Some of these registrars addressed the issue by downgrading to the prior version of the Fury extension.

During this period, 1,470 domain:info commands failed due to this issue, approximately 15% of all domain:info commands executed.

We do not believe that this incident was revenue impacting. It did not affect domain registration or renewal. If the impacts for your registrar were more significant, please let us know, we would like to know more.

We were able to suggest a remediation to the registrars impacted by this issue to downgrade to the Fury-2.0 extension. We believe that many registrars were able to make this change.

Timeline

All times are given in UTC.

  • 2023-11-16 19:00: Fury 8.13 was released

  • 2023-11-17 21:30: Registry service provider support was made aware of the issue and prepared a plan for addressing it

  • 2023-11-18 04:20: Registry posted a notice about the issue on the .eco status board

  • 2023-11-21 22:00: An advisory was sent to all registrars by registry service provider about the issue and containing advice on how to mitigate the issue

  • 2023-11-22 17:00 A fix was deployed for this issue and a notice was sent out about the incident resolution

Duration of incident: 5 days and 22 hours

Time to incident notification: 1 day and 9 hours

Learning and next steps

We had not anticipated that the new versions of extensions provided by the registry in response to an EPP greeting would start getting used immediately. We will take this into account when releasing version upgrades to EPP extensions in the future.

It took us a long time to understand the impact of this issue and communicate to our registrar partners about it. We are looking to improve the speed and thoroughness of our incident response process to make sure that you understand the scope and impact of registry incidents as they occur. Please subscribe to notifications from this status page to ensure that you get notified.

Posted Nov 27, 2023 - 20:22 UTC

Resolved
A fix has now been deployed for this issue in both production and OTE environments. Registrars should no longer experience “2400 Command Failed” if they are using the Fury-2.1 extension. It is still recommended to continue using the Fury-2.0 extension.
Posted Nov 22, 2023 - 17:19 UTC
Identified
This issue was introduced with the Fury 8.13 release on Thu 16 November 2023 and affects some registrars making EPP connections to the .eco registry system (CIRA Fury platform).

Registrars generating their EPP login command based on the EPP greeting response may receive a 2400 Command Failed message on EPP commands.

In the 8.13 release, a Fury-2.1 extension was added to the greeting that appears to be causing an issue if used in the login for commands.

The recommended workaround is to continue logging in to the Fury registry system using the Fury-2.0 extension when connecting via EPP.

Our registry service provider is working on a fix and an update will be released early in the week of 20 November 2023.
Posted Nov 18, 2023 - 04:21 UTC
This incident affected: .eco registry.