.eco portal is down. EPP is still available
Incident Report for eco Domain Registry
Postmortem

The .eco registry web portal was unavailable between 17:21 - 17:37 UTC on January 21 due to a system failure in the firewall used to protect the service. Access was restored after failing over to the backup firewall. Our registry systems partner is working with the firewall vendor to diagnose the cause of the failure. EPP access to the .eco registry was not impacted by this incident.

Posted Feb 03, 2025 - 17:43 UTC

Resolved
This incident has been resolved.
Posted Jan 21, 2025 - 17:37 UTC
Update
We are continuing to investigate this issue.
Posted Jan 21, 2025 - 17:37 UTC
Investigating
We are currently investigating the issue.
Posted Jan 21, 2025 - 17:26 UTC
This incident affected: .eco registry.