Profiles.eco - database upgrade is in progress
Incident Report for eco Domain Registry
Resolved
Deployment is complete
Posted May 24, 2023 - 05:09 UTC
Investigating
There will be momentary downtime during the upgrade
Posted May 24, 2023 - 04:47 UTC
This incident affected: profiles.eco.