Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 18, 2025 - 03:00 UTC
Scheduled
The registry will be performing maintenance to our network infrastructure. This will occur outside of our regularly scheduled monthly deployment window.
There will be intermittent service interruptions (EPP and Web access) throughout that period, with most of the interruptions occurring between 03:00 - 04:00 UTC. You will be notified if the maintenance extends beyond those hours.
Posted Sep 08, 2025 - 17:08 UTC
This scheduled maintenance affected: .eco registry.