Bad deploy on profiles.eco
Incident Report for eco Domain Registry
Resolved
New deploy has resolved the issue
Posted May 08, 2023 - 21:26 UTC
Investigating
A bad deploy is affecting styling and functionality on profiles.eco
Posted May 08, 2023 - 21:20 UTC
This incident affected: profiles.eco.