b.ns.nic.eco transit outage
Incident Report for eco Domain Registry
Postmortem

Incident report - b.ns.nic.eco transit outage

A transit provider used by b.ns.nic.eco, one of the authoritative DNS nameserver clouds used to serve .eco domains, suffered an outage. The outage affected internet connectivity to some of the data centers serving traffic for this NS record. As the data centers have multiple transit providers, only requests reaching the data centers via this transit provider were impacted.This outage did not impact the redundant authoritative nameservers at a.ns.nic.eco. Any failing lookups requests for .eco domains would have automatically failed over to use these nameservers. Other than a slight increase in latency, there was no visible impact to visitors of .eco domains affected by this incident.

Timeline

All times are given in UTC.

  • 2024-02-05 20:53: Incident started

  • 2024-02-05 21:29: Incident was resolved

  • 2024-02-05 21:46: ICANN confirmed resolution of incident

*Duration of incident: 34 minutes

Root cause analysis

One of the transit providers suffered an outage. The transit provider quickly addressed the outage without requiring action from the registry or registry service provider.

Incident Impact

No impact to visitors of .eco domains. This was a regional event that only impacted a proportion of DNS requests within those regions. The redundancy inherent in the authoritative DNS system for .eco domains ensured that there was no visible impact in this brief incident.

Posted Feb 10, 2024 - 00:00 UTC

Resolved
Transit connectivity was restored as of 21:28 UTC.
Posted Feb 05, 2024 - 21:48 UTC
Monitoring
One of the networking providers that provides connectivity to the data centres running .eco nameservers experienced an outage. The .eco registry provider is investigating the issue. We will provide regular updates on the status and impact of this issue.
Posted Feb 05, 2024 - 20:53 UTC
This incident affected: .eco DNS.