Performance regression after last registry deployment

Incident Report for eco Domain Registry

Resolved

We have been monitoring EPP latency for the last 14 hours and are content that the performance issue has been resolved.
Posted Mar 25, 2026 - 19:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 02:34 UTC

Update

We will be deploying an intended fix for this issue between 01:00-02:00 UTC.
Posted Mar 25, 2026 - 00:08 UTC

Identified

The registry platform team has identified the issue and has a fix prepared that is currently being tested. We will update you when we have scheduled the deployment.
Posted Mar 23, 2026 - 21:02 UTC

Update

We are continuing to investigate this issue.
Posted Mar 23, 2026 - 19:42 UTC

Investigating

There was a performance regression after the last .eco registry release on March 12. We are working on resolving this issue as quickly as possible
Posted Mar 12, 2026 - 15:00 UTC
This incident affected: .eco registry.