Google Domains email privacy service is failing
Incident Report for eco Domain Registry
Resolved
This issue appears to be resolved. The backlog of activation emails for .eco domains registered with Google Domains has been cleared.
Posted Jun 03, 2023 - 15:16 UTC
Update
We have raised the issue with Google Domains to resolve.
Posted Jun 01, 2023 - 18:52 UTC
Identified
We are currently unable to deliver activation emails for .eco domains registered with Google Domains due to an issue with their privacy service. If you have registered a domain with Google Domains in the last 24h, and have not received an activation email, our suggested workaround is to temporarily disable privacy on your .eco domain registration. Once you have received the activation email, you can re-enable privacy protection. We have raised this issue with the Google Domains team and will update this status when we have more information.
Posted Jun 01, 2023 - 04:00 UTC
This incident affected: profiles.eco.